RSS Feed kaput?

Alles was die Homepage Fan-Sub.de sowie das Forum und dem Channel betrifft.
808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

RSS Feed kaput?

Beitrag von 808y » 25.04.2009 18:30

Hallo,

da ich nicht so recht weiss in welches Thread ich diesen Topic stellen soll habe ich mal hier reingemacht.
Und zwar der folgende http://fan-sub.de/rss.rhtml .
Früher hab ich diesen in Thunderbird importiert und hatte damit immer die neusten Realeases im Auge, und hatte direkt auch die Übersichtsseite zum jeweiligen Sub gesehen.
Jetzt bekommen ich zwar immer noch die newsten Infos mit, sehe aber nicht die seite zum Sub. Jetzt steht da einfach nur "404 - Not Found".
Der Feed liefert als webseite : z.b. sowas "http://www.fan-sub.de/rss.html?eid=85210" wenn ich das aufrufe bekommen wie gesagt das "404 - Found" was mit Thunderbird sofort anzeigt.
Und nicht die Übersichtsseite zum Anime.

Wäre es irgendwie möglich das zu berichtigen so das ich immer auf die richtige Seite zum anime komme.

Gruß,

808y

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 25.04.2009 18:42

Hm wenn man den Feed mittels Browser aufruft funktioniert es ganz normal, aber wenn man ihn abonniert, z.B. mit Google, sind die Links falsch.

<item>
<title>Isshoni Training 01 (Xvid) (700x400)</title>
<link>http://www.fan-sub.de/fansub.rhtml?id=2288</link>
<description>25.04.2009 - <a href="gruppe.rhtml?id=SpS">SpS</a> - <a href="http://www.anisearch.de/">aniSearch-ID</a></description>
<guid>http://www.fan-sub.de/rss.html?eid=85210</guid>
<pubDate>Sat, 25 Apr 2009 17:07:08 GMT</pubDate>
</item>

http://www.fan-sub.de/fansub.rhtml?id=2288 << das ist der Link zum Anime, den du brauchst
abonniert führt er jedoch zu http://www.fan-sub.de/rss.html?eid=85210

Da scheint wohl ein Fehler bei der Linkgenerierung im guid Element zu sein, musst wohl warten, bis dinoex ihn korrigiert. ;)

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 25.04.2009 18:47

Ah, ok, das trifft ja genau den Fehler.

Dann werde ich mich mal gedulden müssen :D

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 25.04.2009 22:47

Du kannst ja solange den Atom-Feed benutzen. ;)
http://www.fan-sub.de/news.rhtml

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 26.04.2009 15:39

da habe ich aber nur die news, und nicht die releases, was ja praktisch was ganz was anders ist.

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 26.04.2009 16:08

Hm stimmt sry. gar nicht drauf geachtet, habe die Feeds noch nie benutzt, wozu auch...

Du könntest dir auch vorübergehend ein Dynamisches Lesezeichen (Firefox) angelegen, diese "benutzen" nur das "link"-Element.
Wobei du eigentlich gleich auf die fan-sub.de Startseite gehen könntest, ob du die Feeds anschaust oder direkt die Seite, ist doch kein großer Zeitunterschied.
Ansonsten einfach abwarten, bis er deinen Post hier gelesen hat. ;)

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 26.04.2009 17:20

Jap, werde wohl warten müssen.
Der Grund wieso ich nicht Firefox oder so benutzte sondern Thunderbird, ist das man halt sofort ohne klicks den Anime und die beschreibung sieht ohne überhaupt zu klicken, wenn mal ein neuer sub raus ist mit einem namen der mir nichts sagt, sehe ich in thunderbird ohne klick gleich den Beschreibung Bild etc. Zusammen mit dem Allgemeinen Mails ist das für mich ein sehr effizienter News/Mails-Tagesablauf.
Ich denke für viele die Feeds abonieren geht es ähnlich.

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 26.04.2009 19:09

Also ich habe es gerade mal mit Thunderbird probiert, bei mir scheint alles in Ordnung zu sein. Benutzt du irgendwelche entsprechenden Addons (wie rssinfo ..) in Thunderbird?
guid ist für die eindeutige Identifikation, um neue Elemente zu erkennen, anscheinend wurden daher bewusst diese "falschen" guid-Links (durchlaufende Nummerierung) benutzt, damit einzelne Sub-Updates auch als neu angezeigt werden, trotz gleichem Link. Folglich ist das vielleicht durchaus so gewollt. Manche Reader interpretieren das guid-Element dann aber anscheinend als richtigen Link, was natürlich dann zu einem 404 Fehler führt.

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 27.04.2009 15:24

nein ich benutzte keine Addons bei Thunderbird, ganz normal wie man eben in Thunderbird RSS feeds aboniert.
Und ich meine wenn es bei min. 2 Feedreadern zu einer falschen verlinkung führt, kann es ja nicht so gewohlt sein, abgesehen davon das es mir als anwender eigentlich egal ist was das GUID oder so ist, wenn ich weitere infos zum rss feed haben möchte, dann muss es ja zwingend auf den richtigen link verweisen. Das kann also nicht gewollt sein, weil man ja sonst keine chance hat vom feedreader auf die webseite zu kommen.
Es hat übrigens vor ner weile (ca. 1Monat) auch wunderbar geklappt. Ich glaube nur das bei ka. irgendwelchen pflege arbeiten da was kaput gegangen ist.

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 27.04.2009 15:40

Du scheinst meinen Post leider überhaupt nicht verstanden oder gelesen zu haben, aber nun ja spielt keine Rolle... :roll:
- es geht mit Thunderbird
- du kannst nicht davon ausgehen, dass es "kaputt" gegangen ist, da es durchaus gewollt sein kann, wenn auch keine sehr elegante Lösung
- das link-Element verweist auch auf die richtige Seite....
Bild
Zuletzt geändert von Sekai am 31.05.2010 16:19, insgesamt 1-mal geändert.

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 27.04.2009 15:46

hmm. Ok, dann werde ich Thunderbird mal neuinstallen :D Dann frage ich mich aber wieso der Googlereader das auch falsch verlinkt.
Andere Feeds werden bei mir richtig verlinkt, nur eben nicht der von Fansub.de
Hmm. Strange. Aber gut dann hat sich das ja erledigt :D
Nur so ne frage neben bei, ist bei dir JavaScript an?

THX

808y

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 27.04.2009 15:53

Nun ja, das guid-Element sollte trotzdem korrigiert werden, das Element ist rein optional und wird anscheinend von manchen Readern anders behandelt.
Eigentlich soll es einen Link nur genau identifizieren, um seine "Einzigartigkeit" zu gewährleisten.
Also als Beispiel:
Du hast einen Blog mit Feeds, der Link zur Startseite bleibt gleich, aber die Einträge wechseln, so könntest du als <link> den Link zur Hauptseite nehmen und als Guid den Permalink. Der Sinn davon ist, dass gleiche Einträge nicht 2x angezeigt werden. (Daher wird der Guid Element hier wohl mit einem Fakelink versehen) Anscheinend nehmen manche Reader (wie Google) aber dann direkt diesen guid-Link, was zu den gehabten Problemen führt. Also das ist jetzt nur meine Vermutung, ich habe mich noch nie näher mit diesem Thema befasst. ;)

Ich hoffe du kriegst es wieder hin.
Ob javascript an oder aus ist, beeinflusst die Anzeige bei mir jedenfalls nicht.

Benutzeravatar
dinoex
Fan-Sub.de TEAM
Fan-Sub.de TEAM
Beiträge: 616
Registriert: 29.12.2007 06:56
Wohnort: Habichtswald
Kontaktdaten:

Re: RSS Feed kaput?

Beitrag von dinoex » 07.05.2009 13:54

Danke, der Fehler ist jetzt behoben.
mfg Dinoex

808y
Pokito-Fan
Pokito-Fan
Beiträge: 7
Registriert: 25.04.2009 18:20

Re: RSS Feed kaput?

Beitrag von 808y » 08.05.2009 00:07

hmm, also ich hab mein Thunderbird neu installiert und es geht.
Jedoch weigert sich der Googlereader die richtige URL anzuzeigen.
Statt wie bisher auf eine seite zu verweisen die auf "404 Not found" führt. Leitet es jetzt immer auf die Feed url um also z.b.
"http://www.fan-sub.de/rss.rhtml?eid=85374"

Der Googlereader nimmt nachwievor die guid als url auf die er mich meint schicken zu müssen.

Benutzeravatar
dinoex
Fan-Sub.de TEAM
Fan-Sub.de TEAM
Beiträge: 616
Registriert: 29.12.2007 06:56
Wohnort: Habichtswald
Kontaktdaten:

Re: RSS Feed kaput?

Beitrag von dinoex » 30.05.2009 06:09

Bitte Prüfen ob Goggle damit jetzt was anfangen kann.
mfg Dinoex

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 30.05.2009 07:03

dinoex hat geschrieben:Bitte Prüfen ob Goggle damit jetzt was anfangen kann.
Jo, funktioniert nun einwandfrei. :)

obelix
Pokito-Fan
Pokito-Fan
Beiträge: 3
Registriert: 27.12.2008 21:44

Re: RSS Feed kaput?

Beitrag von obelix » 30.05.2009 15:38

kann es sein, dass der rss-Feed seit letzter Nacht wieder kaputt ist? Thunderbird holt sich ständig die kompletten Release neu, obwohl ich die schon hab. Das Problem besteht nur bei dem Release-Feed. Ein Neustart von Thunderbird oder das Neuabbonieren hat nicht geholfen.

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 30.05.2009 16:50

Die Anpassung für den Google RSS-Reader mochte Thunderbird wohl nicht, ich würde daher folgendes vorschlagen:

Code: Alles auswählen

<item>
 <title><![CDATA[Fullmetal Alchemist 2 8 (h264) (1280x720)]]></title>
<link>http://www.fan-sub.de/fansub.rhtml?id=2251</link>
<description>28.05.2009 - <a href="http://www.fan-sub.de/gruppe.rhtml?id=A-F">A-F</a> & <a href="http://www.fan-sub.de/gruppe.rhtml?id=TBF">TBF</a>  - <a href="http://www.anisearch.de/?page=anime&id=5048">aniSearch-ID</a></description>
<guid>http://www.fan-sub.de/fansub.rhtml?id=2251&amp;eid=85632</guid>
<pubDate>Wed, 27 May 2009 22:57:52 GMT</pubDate>
</item>
statt <guid>http://www.fan-sub.de/fansub.rhtml?id=2251&amp;eid=85632</guid>

<guid>http://www.fan-sub.de/fansub.rhtml?id=2251#85632</guid> nehmen

So sollte es mit Firefox, Thunderbird und Google funktionieren, ich kann es leider gerade nicht testen, aber müsste so gehen. :)

Benutzeravatar
dinoex
Fan-Sub.de TEAM
Fan-Sub.de TEAM
Beiträge: 616
Registriert: 29.12.2007 06:56
Wohnort: Habichtswald
Kontaktdaten:

Re: RSS Feed kaput?

Beitrag von dinoex » 30.05.2009 17:27

nein das "#" funktioniert nicht.
Ich habe jetzt ";" verwendet.
mfg Dinoex

Benutzeravatar
Sekai
Selbst schon ein Anime
Selbst schon ein Anime
Beiträge: 1821
Registriert: 07.05.2008 09:42

Re: RSS Feed kaput?

Beitrag von Sekai » 30.05.2009 17:32

Ich habe es gerade bei mir getestet, funktioniert durchaus. (Wird in der RSS Specification auch so als Beispiel aufgeführt.)
?id=2251#35632 das #35632 interessiert den Browser beim Aufruf nicht (den Anker gibt es ja nicht), aber z.B. Thunderbird berücksichtigt es trotzdem, um einzelne Feedeinträge auf ihre Einzigartigkeit zu prüfen. Und bei der Linkgenerierung sollte es auch keinen Unterschied machen, wie du die ID anhängst.

Aber du hast den Fehler ja nun anders gelöst, das ist die Hauptsache. ;)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste